News: No news is good news...

Login  |  Register

Author Topic: PM button puts wrong username in "To:" box  (Read 1853 times)

0 Members and 1 Guest are viewing this topic.

Offline LoH

  • Full Member
  • ***
  • Posts: 542
  • Country: us
  • MODEL ALL THE PAINTS!
    • SIUC Strategic Games Society
  • Armies: IG,SW,SoB,Chaos Cultist,ImpFist 5C,INQ
PM button puts wrong username in "To:" box
« on: July 17, 2013, 04:06:19 PM »
Currently, the PM button on the forums uses the currently-displayed name as the username when sending a PM, which then causes issues when one tries to actually send it (user doesn't exist error).

One of the current test cases is Oink, whose current displayed name "Shas'Oink" does not match his actual username "Oink". Clicking the PM button on a post made by him will bring up the PM send dialog, but addressed to "shas'oink".
PAINT ALL THE MODELS!

Offline Scorn

  • Supreme Archon of Commorragh | Nasty Sky Juice | Title (and/or) Whore |
  • Ancient
  • Senior Member
  • *****
  • Posts: 2912
  • Country: 00
  • Armies: Craftworld Eldar
Re: PM button puts wrong username in "To:" box
« Reply #1 on: July 21, 2013, 12:59:07 PM »
Likely the difference between the currently displayed name and the account name used when the account was first created.  PMs would be sent to the account name which will not necessarily match the current user name.  Try me, what do you see?
Rejoice.  Despair. 
Fate does not care.
Each knotted mind entwined. 
Each soul another's bind.
And blind though we are led. 
In time we do know when, to cut a thread.
-Erfworld

 


Powered by EzPortal